Talk:How-to Create a TI-83 Plus ROM Image


Jump to: navigation, search


Help, please!

Somehow when I tried to downgrade my TI-83 Plus's OS from 1.19 to 1.12 it just froze and gave me an error, making my calculator useless. Any help on this would be great. -Megamanfan3


I know you posted August of 2006, but it appears 1.12 is CORRUPTED. Upon a dump, VirtualTI recognized it as TI-86 version 1.01! To fix it, press 2nd+OFF then 2nd+ON, hook it up, and transfer 1.19 to the calculator as normal. You can also see your calculator by using the TI ScreenCapture utility in TI Connect. XPMaster 18:01, 17 January 2008 (EST)

My instructions were for the TI-83+ calculator. It worked fine for me on my system with it showing up in VTI as TI-83+ 1.12.


Can someone help me pack the files into a ROM for my TI-84 Plus? Storm 20:54, 4 December 2008 (EST)

TI-84 Plus is a very similar system to the 83+ (just faster and more memory). Have you tried the steps on the site?
Yes, but I can not get the command right to pack the files into the ROM. I don't think I'm entering the OS right for the command. (Step 10)
I'm sorry but I don't know what's going on with you calculator. They may have changed things for the 84. Since I don't have one I don't know what's going on. Look for the alternate method listed on the article. -ThePlaz 20:57, 5 December 2008 (EST)

Trouble with the Command Prompt

I've done everything said in both your guide and the rom8x Readme, but every time I try to do the part with the command prompt, it gives me an error. I enter "cd \Documents and Settings\Admin\Desktop\New Folder" and no problem. Then I enter "cd \rom8x" and it returns "the system cannot find the path specified". I checked, double checked, and triple checked your guide, the Readme, and the name of the file, but still the same results. The Readme told me a list of errors, none of which included this one, and then it said "There are probably a few more, but they are self-explanatory." What should I do?

Your visible username my differ from your "actual" username. Go Start>My Computer>C>Documents and Settings>Admin>Desktop>New Folder to make sure it is there. The username may be different. Then make sure the rom8x file is in that folder. Right click on it and open properties. What is the path to that file. --ThePlaz 23:49, 21 June 2009 (EDT)

Ever since that post I've had to move the files around a little, but it was there at the time. This is the new path to the file copied and pasted from the properties "C:\Documents and Settings\Admin\Desktop\Calculator Stuff\Virtual TI 2.5\New Folder" I was able to get the Virtual TI 3.0 working without the ROM dump, but for some reason I couldn't load any programs, only applications, and I couldn't save state, so I tried tilem, and it's working perfectly now, using the roms from the TI 83+ Flash Debugger, except it for some reason only loads so many programs (I put the 20 programs on my calculator onto my PC, and then loaded them into the emulator, and it only showed the first 12 after I turned it off and got back on later)